4.134. libgpg-error

An updated libgpg-error package is now available for Red Hat Enterprise Linux 6.
The libgpg-error library provides a set of common error codes and definitions which are shared by the gnupg, libgcrypt and other packages.

Enhancement

BZ#727287
Previously, the libgpg-error package was compiled without the RELRO (read-only relocations) flag. Programs provided by this package were thus vulnerable to various attacks based on overwriting the ELF section of a program. To increase the security of the libgpg-error library, the libgpg-error spec file has been modified to use the "-Wl,-z,relro" flags when compiling the package. As a result, the libgpg-error package is now provided with partial RELRO protection.
Users of libgpg-error are advised to upgrade to this updated package, which adds this enhancement.