"User has exceeded the maximum number of offline sessions" message when trying to retrieve Offline Access Token for ROSA

Solution Verified - Updated -

Environment

Red Hat OpenShift Service on AWS (ROSA)
Red Hat OpenShift Cluster Manager (RHOCM)

Issue

When trying to retrieve Offline Access Token from https://cloud.redhat.com/openshift/token/rosa , the page shows the following error:

{"error":"offline_session_limit_exceeded","error_description":"User has exceeded the maximum number of offline sessions.  Please visit the session management page for more details."}

Resolution

  • Revoke older Offline Access Tokens at the "Application" page for your Red Hat Account.

If the above does not work,

  • On https://cloud.redhat.com/openshift/token/rosa, at the profile top right corner, click Log Out.
    Then revisit the same page, and generate a token.

Root Cause

The tokens are long lived and should be stored locally once generated for later use.

If you try to repeatedly retrieve the Offline Access Token from Tokens / ROSA then eventually this limit is hit as too many tokens have been generated.

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