How to install libnsl.so.1 in Red Hat Enterprise Linux 8.1?

Solution Verified - Updated -

Issue

  • Unable to install NetBackup Utility 8.2 in RHEL8.1 due to missing /usr/lib64/libnsl.so.1 library. The application installation fails with the following error:

    # /usr/openv/netbackup/bin/bpclntcmd -pn
    
    /usr/openv/netbackup/bin/bpclntcmd: /lib64/libnsl.so.1: version `GLIBC_2.2.5' not found (required by /usr/openv/netbackup/bin/bpclntcmd)
    
  • Third party application installation fails with the following errors on RHEL8.1 :

    /lib64/libnsl.so.1: version `GLIBC_2.2.5' not found 
    

Environment

  • Red Hat Enterprise Linux 8.1
  • libnsl-2.28-72.el8.x86_64

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In