yum update fails with libsmbios conflicts on systems with Dell EMC OMSA installed

Solution In Progress - Updated -

Issue

  • Dell OMSA: yum update fails with libsmbios conflicts
  • RHEL provided libsmbios causes RPM dependency issue when Dell OMSA installed on system.

    --> Package Error: Package: srvadmin-storage
               Requires: libsmbios.so.2()(64bit)
               Removing: libsmbios-2.3.3-7.el7.x86_64 (@epel)
                   libsmbios.so.2()(64bit)
               Updated By: libsmbios-2.3.3-8.el7.x86_64 (rhel7)
                   Not found
    

Environment

  • Red Hat Enterprise Linux 7.5
  • libsmbios-2.3.3-6.el7 (or later)
  • Dell EMC OMSA (OpenManage Server Administrator)

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In