On Red Hat Satellite 5.8 schema upgrade fails to drop table rhnSolarisPatchedPackage for satellite-schema version 5.8.0.40.

Solution Verified - Updated -

Issue

  • Upgrading Satellite-schmea for Red Hat Satellite-5.8 to version 5.8.0.40 fails with below error message in schema-upgrade logs:

    # cat /var/log/spacewalk/schema-upgrade/20180205-094746-to-satellite-schema-5.8.0.40.log
    UPDATE 1
    COMMIT
                                                    ?column?                                                 
    ---------------------------------------------------------------------------------------------------------
     satellite-schema-5.8.0.38-to-satellite-schema-5.8.0.39/001-rhnpackageevr-rhn_pe_v_r_e_uq.sql.postgresql
    (1 row)
    
    CREATE FUNCTION
    DROP TRIGGER
     psql:/var/log/spacewalk/schema-upgrade/20180205-094746-script.sql:58: ERROR:  relation "rhnsolarispatchedpackage" does not exist
     LINE 1: update rhnsolarispatchedpackage set package_nevra_id = nevra...
    

Environment

  • Red Hat Satellite 5.8
  • Satellite-schema-5.8.0.40-1.el6sat

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In