Are OpenShift Enterprise 3.1 and earlier compatible with Docker 1.9+?

Solution Verified - Updated -

Issue

  • Docker 1.9 is available in RHEL 7.2 and RHEL Atomic Host 7.2.3. Docker 1.10 is also available in RHEL 7.2 and RHEL Atomic Host 7.2.5. OSE 3.1 documentation1 cites a requirement of Docker 1.8.2. Are OSE 3.1 and Docker 1.9+ compatible?

Environment

  • Red Hat Enterprise Linux (RHEL) 7.2 or RHEL Atomic Host 7.2.3
  • OpenShift Enterprise (OSE) 3.1 or 3.0
  • Atomic Enterprise Platform (AEP) 3.1
  • Docker 1.8.2, 1.9.1, and 1.10.3

NOTE: Any reference in this solution to OSE also applies to AEP, as they share a common code base.

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In