rhel7: Open VM Tools - please include deploypkg

Solution Verified - Updated -

Issue

  • In order create a template that is customizable on deployment, it is necessary to manually install the open-vm-tools-deploypkg package from the VMWare repositories in addition to the open tools provided by Redhat from the following repo VMware RHEL7
  • I am using VMware repositories to retrieve open-vm-tools-deploypkg on RHEL7, trying to update to RHEL7.2 I see this issue:
--> Running transaction check
---> Package libxshmfence.x86_64 0:1.2-1.el7 will be installed
---> Package open-vm-tools.x86_64 0:9.4.0-6.el7 will be updated
--> Processing Dependency: open-vm-tools < 9.5 for package: open-vm-tools-deploypkg-9.4.10-3.x86_64
---> Package python-perf.x86_64 0:3.10.0-327.3.1.el7 will be installed
--> Finished Dependency Resolution
Error: Package: open-vm-tools-deploypkg-9.4.10-3.x86_64 (@/open-vm-tools-deploypkg-9.4.10-3.x86_64)
           Requires: open-vm-tools < 9.5
           Removing: open-vm-tools-9.4.0-6.el7.x86_64 (@rhel-base)
               open-vm-tools = 9.4.0-6.el7
           Updated By: open-vm-tools-9.10.2-4.el7.x86_64 (rhel-x86_64-server-7)
               open-vm-tools = 9.10.2-4.el7
           Available: open-vm-tools-9.4.0-3.el7.x86_64 (rhel-x86_64-server-7)
               open-vm-tools = 9.4.0-3.el7
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Environment

  • Red Hat Enterprise Linux 7
  • vmware

Subscriber exclusive content

A Red Hat subscription provides unlimited access to our knowledgebase of over 48,000 articles and solutions.

Current Customers and Partners

Log in for full access

Log In