CVE-2019-8905

Impact:
Moderate
Public Date:
2019-02-18
CWE:
CWE-125
Bugzilla:
1679181: CVE-2019-8905 file: stack-based buffer over-read in do_core_note in readelf.c

The MITRE CVE dictionary describes this issue as:

do_core_note in readelf.c in libmagic.a in file 5.35 has a stack-based buffer over-read, related to file_printable, a different vulnerability than CVE-2018-10360.

Find out more about CVE-2019-8905 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 5.4
CVSS3 Base Metrics CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Attack Vector Adjacent Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact Low

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux rh-php70-php Under investigation
Red Hat Software Collections for Red Hat Enterprise Linux rh-php71-php Under investigation
Red Hat Enterprise Linux 8 file Affected
Red Hat Enterprise Linux 7 php Under investigation
Red Hat Enterprise Linux 7 file Not affected
Red Hat Enterprise Linux 6 file Not affected
Red Hat Enterprise Linux 6 php Under investigation
Red Hat Enterprise Linux 5 php53 Under investigation
Red Hat Enterprise Linux 5 file Not affected
Last Modified

CVE description copyright © 2017, The MITRE Corporation