CVE-2019-2762

Impact:
Moderate
Public Date:
2019-07-16
Bugzilla:
1730415: CVE-2019-2762 OpenJDK: Insufficient checks of suppressed exceptions in deserialization (Utilities, 8212328)

The MITRE CVE dictionary describes this issue as:

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Utilities). Supported versions that are affected are Java SE: 7u221, 8u212, 11.0.3 and 12.0.1; Java SE Embedded: 8u211. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Java SE, Java SE Embedded. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.0 Base Score 5.3 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L).

Find out more about CVE-2019-2762 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 5.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality None
Integrity Impact None
Availability Impact Low

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (java-1.7.0-openjdk) RHSA-2019:1840 2019-07-23
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.8.0-ibm) RHSA-2019:2592 2019-09-03
Red Hat Enterprise Linux 8 (java-1.8.0-openjdk) RHSA-2019:1816 2019-07-22
Red Hat Enterprise Linux 8 (java-11-openjdk) RHSA-2019:1817 2019-07-22
Red Hat Enterprise Linux 7 (java-1.7.0-openjdk) RHSA-2019:1839 2019-07-23
Red Hat Enterprise Linux 6 (java-1.8.0-openjdk) RHSA-2019:1811 2019-07-22
Red Hat Enterprise Linux 8 (java-1.8.0-ibm) RHSA-2019:2590 2019-09-02
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.7.1-ibm) RHSA-2019:2495 2019-08-15
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.8.0-ibm) RHSA-2019:2585 2019-09-02
Red Hat Enterprise Linux 7 (java-1.8.0-openjdk) RHSA-2019:1815 2019-07-22
Red Hat Satellite 5.8 (RHEL v.6) (java-1.8.0-ibm) RHSA-2019:2737 2019-09-11
Red Hat Enterprise Linux 7 (java-11-openjdk) RHSA-2019:1810 2019-07-22
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.7.1-ibm) RHSA-2019:2494 2019-08-15
Last Modified

CVE description copyright © 2017, The MITRE Corporation