CVE-2019-2684

Impact:
Moderate
Public Date:
2019-04-16
Bugzilla:
1700564: CVE-2019-2684 OpenJDK: Incorrect skeleton selection in RMI registry server-side dispatch handling (RMI, 8218453)

The MITRE CVE dictionary describes this issue as:

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: RMI). Supported versions that are affected are Java SE: 7u211, 8u202, 11.0.2 and 12; Java SE Embedded: 8u201. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE, Java SE Embedded accessible data. Note: This vulnerability applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets (in Java SE 8), that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. This vulnerability can also be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. CVSS 3.0 Base Score 5.9 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N).

Find out more about CVE-2019-2684 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 5.9
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality None
Integrity Impact High
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (java-1.7.0-openjdk) RHSA-2019:0790 2019-04-22
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.8.0-ibm) RHSA-2019:1164 2019-05-13
Red Hat Enterprise Linux 6 (java-1.8.0-openjdk) RHSA-2019:0774 2019-04-17
Red Hat Enterprise Linux 7 (java-1.8.0-openjdk) RHSA-2019:0775 2019-04-17
Red Hat Enterprise Linux 8 (java-1.8.0-ibm) RHSA-2019:1238 2019-05-16
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.7.1-ibm) RHSA-2019:1165 2019-05-13
Red Hat Satellite 5.8 (RHEL v.6) (java-1.8.0-ibm) RHSA-2019:1325 2019-06-04
Red Hat Enterprise Linux 8 (java-1.8.0-openjdk) RHSA-2019:1146 2019-05-13
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.8.0-ibm) RHSA-2019:1163 2019-05-13
Red Hat Enterprise Linux 7 (java-1.7.0-openjdk) RHSA-2019:0791 2019-04-22
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.7.1-ibm) RHSA-2019:1166 2019-05-13
Red Hat Enterprise Linux 7 (java-11-openjdk) RHSA-2019:0778 2019-04-17

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 8 java-11-openjdk Affected
Last Modified

CVE description copyright © 2017, The MITRE Corporation