CVE-2019-14378

Impact:
Important
Public Date:
2019-07-28
CWE:
CWE-122
Bugzilla:
1734745: CVE-2019-14378 QEMU: slirp: heap buffer overflow during packet reassembly
A heap buffer overflow issue was found in the SLiRP networking implementation of the QEMU emulator. This flaw occurs in the ip_reass() routine while reassembling incoming packets if the first fragment is bigger than the m->m_dat[] buffer. An attacker could use this flaw to crash the QEMU process on the host, resulting in a Denial of Service or potentially executing arbitrary code with privileges of the QEMU process.

Find out more about CVE-2019-14378 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

Red Hat OpenStack Platform:
* This flaw impacts KVM user-mode or SLIRP networking, which is not used in Red Hat OpenStack Platform. Although updating is recommended for affected versions (see below), Red Hat OpenStack Platform environments are not vulnerable.
* Because the flaw's impact is Low, it will not be fixed in Red Hat OpenStack Platform 9 which is retiring within a few weeks of the flaw's public date.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 7
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H
Attack Vector Local
Attack Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Low
Integrity Impact Low
Availability Impact High

Affected Packages State

Platform Package State
Red Hat OpenStack Platform 9.0 qemu-kvm-rhev Will not fix
Red Hat OpenStack Platform 14.0 (Rocky) qemu-kvm-rhev Affected
Red Hat OpenStack Platform 13.0 (Queens) qemu-kvm-rhev Affected
Red Hat OpenStack Platform 10 qemu-kvm-rhev Affected
Red Hat Enterprise Linux 8 qemu-kvm Affected
Red Hat Enterprise Linux 7 qemu-kvm-rhev Affected
Red Hat Enterprise Linux 7 qemu-kvm Affected
Red Hat Enterprise Linux 7 qemu-kvm-ma Affected
Red Hat Enterprise Linux 6 qemu-kvm Affected
Red Hat Enterprise Linux 5 kvm Out of support scope
Red Hat Enterprise Linux 5 xen Not affected
Unless explicitly stated as not affected, all previous versions of packages in any minor update stream of a product listed here should be assumed vulnerable, although may not have been subject to full analysis.

Acknowledgements

Red Hat would like to thank Vishnu Dev for reporting this issue.

Mitigation

There is no external mitigation to prevent this out-of-bounds heap memory access.

Last Modified