CVE-2019-10164

Impact:
Moderate
Public Date:
2019-06-20
CWE:
CWE-121
Bugzilla:
1719698: CVE-2019-10164 PostgreSQL: stack-based buffer overflow via setting a password

The MITRE CVE dictionary describes this issue as:

PostgreSQL versions 10.x before 10.9 and versions 11.x before 11.4 are vulnerable to a stack-based buffer overflow. Any authenticated user can overflow a stack-based buffer by changing the user's own password to a purpose-crafted value. This often suffices to execute arbitrary code as the PostgreSQL operating system account.

Find out more about CVE-2019-10164 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 7.5
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality High
Integrity Impact High
Availability Impact High

Affected Packages State

Platform Package State
Red Hat Virtualization 4 rh-postgresql10-postgresql Affected
Red Hat Virtualization 4 rh-postgresql95-postgresql Not affected
Red Hat Virtualization 4 rh-postgresql95 Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql10-postgresql Affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql96-postgresql Not affected
Red Hat Satellite 6 postgresql Not affected
Red Hat Satellite 5 rh-postgresql95-postgresql Not affected
Red Hat Satellite 5 rh-postgresql95 Not affected
Red Hat Enterprise Linux 8 libpq Affected
Red Hat Enterprise Linux 8 postgresql:10/postgresql Affected
Red Hat Enterprise Linux 8 postgresql:9.6/postgresql Not affected
Red Hat Enterprise Linux 8 postgresql Affected
Red Hat Enterprise Linux 7 postgresql Not affected
Red Hat Enterprise Linux 6 postgresql Not affected
Red Hat Enterprise Linux 5 postgresql Not affected

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation