CVE-2019-10127

Impact:
Moderate
Public Date:
2019-05-09
CWE:
CWE-284
Bugzilla:
1707098: CVE-2019-10127 postgresql: BigSQL installer does not clear permissive ACL entries
The Windows installer for BigSQL-supplied PostgreSQL does not lock down the ACL of the binary installation directory or the ACL of the data directory; it keeps the inherited ACL. In the default configuration, an attacker having both an unprivileged Windows account and an unprivileged PostgreSQL account can cause the PostgreSQL service account to execute arbitrary code. An attacker having only the unprivileged Windows account can read arbitrary data directory files, essentially bypassing database-imposed read access limitations. An attacker having only the unprivileged Windows account can also delete certain data directory files.

Find out more about CVE-2019-10127 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 7.8
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Attack Vector Local
Attack Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality High
Integrity Impact High
Availability Impact High

Affected Packages State

Platform Package State
Red Hat Virtualization 4 postgresql Not affected
Red Hat Virtualization 4 rh-postgresql95 Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql10-postgresql Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql95-postgresql Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql96-postgresql Not affected
Red Hat Satellite 6 postgresql Not affected
Red Hat Satellite 5 rh-postgresql95-postgresql Not affected
Red Hat Enterprise Linux 8 libpq Not affected
Red Hat Enterprise Linux 8 postgresql Not affected
Red Hat Enterprise Linux 7 postgresql Not affected
Red Hat Enterprise Linux 6 postgresql Not affected
Red Hat Enterprise Linux 5 postgresql Not affected
Red Hat Ansible Tower 3 for RHEL 7 postgresql96-libs Not affected

Acknowledgements

Red Hat would like to thank Noah Misch and the PostgreSQL Project for reporting this issue. Upstream acknowledges Conner Jones as the original reporter.

External References

Last Modified