CVE-2019-1003012

Impact:
Moderate
Public Date:
2019-01-28
CWE:
CWE-352
Bugzilla:
1670298: CVE-2019-1003012 jenkins-plugin-blueocean: Blue Ocean did not require CSRF tokens (SECURITY-1201)

The MITRE CVE dictionary describes this issue as:

A data modification vulnerability exists in Jenkins Blue Ocean Plugins 1.10.1 and earlier in blueocean-core-js/src/js/bundleStartup.js, blueocean-core-js/src/js/fetch.ts, blueocean-core-js/src/js/i18n/i18n.js, blueocean-core-js/src/js/urlconfig.js, blueocean-rest/src/main/java/io/jenkins/blueocean/rest/APICrumbExclusion.java, blueocean-web/src/main/java/io/jenkins/blueocean/BlueOceanUI.java, blueocean-web/src/main/resources/io/jenkins/blueocean/BlueOceanUI/index.jelly that allows attackers to bypass all cross-site request forgery protection in Blue Ocean API.

Find out more about CVE-2019-1003012 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

Red Hat OpenShift Container Platform 3.10:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 3.4:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 3.5:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 3.6:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 3.7:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 3.9:
This vulnerability has been rated as having a security impact of Moderate. After evaluation and in accordance with the criteria noted in the product support life cycle, there are no plans to address this issue in an upcoming release. Please contact Red Hat Support for further information.

Red Hat OpenShift Container Platform 4.1:
This vulnerability is currently targeted to be addressed in an upcoming release.

CVSS v3 metrics

CVSS3 Base Score 7.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality High
Integrity Impact High
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat OpenShift Container Platform 3.11 (jenkins-2-plugins) RHBA-2019:0326 2019-02-20

Affected Packages State

Platform Package State
Red Hat OpenShift Container Platform 4.1 jenkins-2-plugins Affected
Red Hat OpenShift Container Platform 3.9 jenkins-plugin-blueocean Will not fix
Red Hat OpenShift Container Platform 3.7 jenkins-plugin-blueocean Will not fix
Red Hat OpenShift Container Platform 3.6 jenkins-plugin-blueocean Will not fix
Red Hat OpenShift Container Platform 3.5 jenkins-plugin-blueocean Will not fix
Red Hat OpenShift Container Platform 3.4 jenkins-plugin-blueocean Will not fix
Red Hat OpenShift Container Platform 3.10 jenkins-plugin-blueocean Will not fix
Unless explicitly stated as not affected, all previous versions of packages in any minor update stream of a product listed here should be assumed vulnerable, although may not have been subject to full analysis.

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation