CVE-2018-2582

Impact:
Important
Public Date:
2018-01-16
Bugzilla:
1534768: CVE-2018-2582 OpenJDK: insufficient validation of the invokeinterface instruction (Hotspot, 8174962)

The MITRE CVE dictionary describes this issue as:

Vulnerability in the Java SE, Java SE Embedded component of Oracle Java SE (subcomponent: Hotspot). Supported versions that are affected are Java SE: 8u152 and 9.0.1; Java SE Embedded: 8u151. Easily exploitable vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Java SE, Java SE Embedded. Successful attacks require human interaction from a person other than the attacker. Successful attacks of this vulnerability can result in unauthorized creation, deletion or modification access to critical data or all Java SE, Java SE Embedded accessible data. Note: This vulnerability applies to client and server deployment of Java. This vulnerability can be exploited through sandboxed Java Web Start applications and sandboxed Java applets. It can also be exploited by supplying data to APIs in the specified Component without using sandboxed Java Web Start applications or sandboxed Java applets, such as through a web service. CVSS 3.0 Base Score 6.5 (Integrity impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N).

Find out more about CVE-2018-2582 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 6.5
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality None
Integrity Impact High
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Oracle Java for Red Hat Enterprise Linux 6 (java-1.8.0-oracle) RHSA-2018:0099 2018-01-18
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.8.0-ibm) RHSA-2018:0352 2018-02-26
Red Hat Enterprise Linux Supplementary (v. 6) (java-1.7.1-ibm) RHSA-2018:0521 2018-03-14
Red Hat Satellite 5.8 (RHEL v.6) (java-1.8.0-ibm) RHSA-2018:1463 2018-05-15
Red Hat Enterprise Linux 7 (java-1.8.0-openjdk) RHSA-2018:0095 2018-01-17
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.7.1-ibm) RHSA-2018:0458 2018-03-07
Red Hat Enterprise Linux Supplementary (v. 7) (java-1.8.0-ibm) RHSA-2018:0351 2018-02-26
Red Hat Enterprise Linux 6 (java-1.8.0-openjdk) RHSA-2018:0095 2018-01-17
Oracle Java for Red Hat Enterprise Linux 7 (java-1.8.0-oracle) RHSA-2018:0099 2018-01-18

Affected Packages State

Platform Package State
Red Hat Satellite 5 java-1.7.1-ibm Affected
Red Hat Enterprise Linux 7 java-1.7.0-openjdk Not affected
Red Hat Enterprise Linux 6 java-1.6.0-ibm Will not fix
Red Hat Enterprise Linux 6 java-1.7.0-openjdk Not affected

Last Modified

CVE description copyright © 2017, The MITRE Corporation

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.