CVE-2018-20023

Impact:
Low
Public Date:
2018-12-19
CWE:
CWE-665
Bugzilla:
1661128: CVE-2018-20023 libvncserver: Improper initialization in VNC Repeater client code allows for information disclosure

The MITRE CVE dictionary describes this issue as:

LibVNC before 8b06f835e259652b0ff026898014fc7297ade858 contains CWE-665: Improper Initialization vulnerability in VNC Repeater client code that allows attacker to read stack memory and can be abuse for information disclosure. Combined with another vulnerability, it can be used to leak stack memory layout and in bypassing ASLR

Find out more about CVE-2018-20023 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 4.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact None

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 7 libvncserver Not affected
Red Hat Enterprise Linux 6 libvncserver Not affected

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation