CVE-2018-16845

Impact:
Important
Public Date:
2018-11-06
Bugzilla:
1644508: CVE-2018-16845 nginx: Denial of service and memory disclosure via mp4 module
An instance of missing input sanitization was found in the mp4 module for nginx. A local attacker could create a specially crafted video file that, when streamed by the server, would cause a denial of service (server crash or hang) and, possibly, information disclosure.

Find out more about CVE-2018-16845 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 8.2
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-nginx18-nginx) RHSA-2018:3652 2018-11-26
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-nginx110-nginx) RHSA-2018:3653 2018-11-26
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-nginx112-nginx) RHSA-2018:3680 2018-11-27
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-nginx114-nginx) RHSA-2018:3681 2018-11-27
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-nginx110-nginx) RHSA-2018:3653 2018-11-26
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-nginx18-nginx) RHSA-2018:3652 2018-11-26

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 8 nginx Not affected
Red Hat Ansible Tower 3 for RHEL 7 nginx Not affected
CloudForms Management Engine 5 nginx Not affected
Unless explicitly stated as not affected, all previous versions of packages in any minor update stream of a product listed here should be assumed vulnerable, although may not have been subject to full analysis.

Acknowledgements

Red Hat would like to thank the Nginx project for reporting this issue.

External References

Last Modified