CVE-2018-14681

Impact:
Low
Public Date:
2017-11-26
CWE:
CWE-787
Bugzilla:
1610896: CVE-2018-14681 libmspack: out-of-bounds write in kwajd_read_headers in mspack/kwajd.c

The MITRE CVE dictionary describes this issue as:

An issue was discovered in kwajd_read_headers in mspack/kwajd.c in libmspack before 0.7alpha. Bad KWAJ file header extensions could cause a one or two byte overwrite.

Find out more about CVE-2018-14681 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the versions of libmspack as shipped with Red Hat Enterprise Linux 7.

CVSS v3 metrics

CVSS3 Base Score 4.4
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:L
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality None
Integrity Impact Low
Availability Impact Low

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (libmspack) RHSA-2018:3327 2018-10-30

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 8 libmspack Not affected
Last Modified

CVE description copyright © 2017, The MITRE Corporation