CVE-2018-10904

Impact:
Important
Public Date:
2018-09-04
CWE:
CWE-426
Bugzilla:
1601298: CVE-2018-10904 glusterfs: Unsanitized file names in debug/io-stats translator can allow remote attackers to execute arbitrary code
It was found that glusterfs server does not properly sanitize file paths in the "trusted.io-stats-dump" extended attribute which is used by the "debug/io-stats" translator. An attacker can use this flaw to create files and execute arbitrary code. To exploit this, the attacker would require sufficient access to modify the extended attributes of files on a gluster volume.

Find out more about CVE-2018-10904 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue did not affect Red Hat Enterprise Linux 6 and 7 as the flaw is present in glusterfs-server, which is not shipped there.

This flaw affects glusterfs versions included in Red Hat Virtualization 4 Hypervisor. However, in recommended configurations, the vulnerability is only exposed to hypervisor administrators and can not be exploited from virtual machines or other hosts on the network. For Red Hat Virtualization, Product Security has rated this flaw as Moderate. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

CVSS v3 metrics

CVSS3 Base Score 8.8
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality High
Integrity Impact High
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat Gluster Storage 3.4 for RHEL 6 (glusterfs) RHSA-2018:2608 2018-09-04
Red Hat Storage Native Client for Red Hat Enterprise Linux 6 (glusterfs) RHSA-2018:2608 2018-09-04
Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts RHSA-2018:3470 2018-11-05
Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts RHSA-2018:2607 2018-09-04
Red Hat Storage Native Client for Red Hat Enterprise Linux 7 (glusterfs) RHSA-2018:2607 2018-09-04
Red Hat Gluster Storage 3.4 for RHEL 7 (glusterfs) RHSA-2018:2607 2018-09-04

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 7 glusterfs Not affected
Red Hat Enterprise Linux 6 glusterfs Not affected

Acknowledgements

Red Hat would like to thank Michael Hanselmann (hansmi.ch) for reporting this issue.

Mitigation

To limit exposure of gluster server nodes :

1. gluster server should be on LAN and not reachable from public networks.
2. Use gluster auth.allow and auth.reject.
3. Use TLS certificates to authenticate gluster clients.

caveat: This does not protect from attacks against authenticated gluster clients.

Last Modified