CVE-2018-1089

Impact:
Important
Public Date:
2018-05-07
CWE:
CWE-122
Bugzilla:
1559802: CVE-2018-1089 389-ds-base: ns-slapd crash via large filter value in ldapsearch
It was found that 389-ds-base did not properly handle long search filters with characters needing escapes, possibly leading to buffer overflows. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.

Find out more about CVE-2018-1089 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 7.5
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality None
Integrity Impact None
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (389-ds-base) RHSA-2018:1380 2018-05-14
Red Hat Enterprise Linux 6 (389-ds-base) RHSA-2018:1364 2018-05-09

Acknowledgements

Red Hat would like to thank Greg Kubok for reporting this issue.

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.