CVE-2018-1000168

Impact:
Moderate
Public Date:
2018-04-12
CWE:
CWE-476
Bugzilla:
1565035: CVE-2018-1000168 nghttp2: Null pointer dereference when too large ALTSVC frame is received

The MITRE CVE dictionary describes this issue as:

nghttp2 version >= 1.10.0 and nghttp2 <= v1.31.0 contains an Improper Input Validation CWE-20 vulnerability in ALTSVC frame handling that can result in segmentation fault leading to denial of service. This attack appears to be exploitable via network client. This vulnerability appears to have been fixed in >= 1.31.1.

Find out more about CVE-2018-1000168 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 5.9
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality None
Integrity Impact None
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat JBoss Core Services 1 RHSA-2019:0366 2019-02-18
Red Hat JBoss Core Services on RHEL 6 Server RHSA-2019:0367 2019-02-18
Red Hat JBoss Core Services on RHEL 7 Server RHSA-2019:0367 2019-02-18

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux httpd24-nghttp2 Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-nodejs8-nodejs Not affected
Red Hat Enterprise Linux 8 nghttp2 Not affected

Acknowledgements

Red Hat would like to thank the Nghttp2 project for reporting this issue.
Last Modified

CVE description copyright © 2017, The MITRE Corporation