CVE-2017-7890

Impact:
Moderate
Public Date:
2017-07-10
CWE:
CWE-20
Bugzilla:
1473822: CVE-2017-7890 php: Buffer over-read from unitialized data in gdImageCreateFromGifCtx function
A data leak was found in gdImageCreateFromGifCtx() in GD Graphics Library used in PHP before 5.6.31 and 7.1.7. An attacker could craft a malicious GIF image and read up to 762 bytes from stack.

Find out more about CVE-2017-7890 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

Red Hat Product Security has rated this issue as having Moderate security impact. This issue is not currently planned to be addressed in future updates. We recommend avoiding usage of the functions gdImageCreateFromGifCtx() and imagecreatefromstring() as they can lead to stack data leak.

For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

CVSS v3 metrics

CVSS3 Base Score 5.5
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Attack Vector Local
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality High
Integrity Impact None
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-php70-php) RHSA-2018:1296 2018-05-03
Red Hat Enterprise Linux 7 (php) RHSA-2018:0406 2018-03-06
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-php70-php) RHSA-2018:1296 2018-05-03

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux rh-php56-php Will not fix
Red Hat OpenShift Enterprise 2 php Will not fix
Red Hat Enterprise Linux 6 php Will not fix
Red Hat Enterprise Linux 5 php53 Will not fix
Red Hat Enterprise Linux 5 php Will not fix

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.