CVE-2017-5455

Impact:
Important
Public Date:
2017-04-19
Bugzilla:
1443334: CVE-2017-5455 Mozilla: Sandbox escape through internal feed reader APIs (MFSA 2017-12)

The MITRE CVE dictionary describes this issue as:

The internal feed reader APIs that crossed the sandbox barrier allowed for a sandbox escape and escalation of privilege if combined with another vulnerability that resulted in remote code execution inside the sandboxed process. This vulnerability affects Firefox ESR < 52.1 and Firefox < 53.

Find out more about CVE-2017-5455 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 7.5
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality High
Integrity Impact High
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (firefox) RHSA-2017:1106 2017-04-21

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 7 thunderbird Not affected
Red Hat Enterprise Linux 6 firefox Not affected
Red Hat Enterprise Linux 6 thunderbird Not affected
Red Hat Enterprise Linux 5 firefox Will not fix
Red Hat Enterprise Linux 5 thunderbird Will not fix

Acknowledgements

Red Hat would like to thank the Mozilla project for reporting this issue. Upstream acknowledges Paul Theriault as the original reporter.

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation