CVE-2017-3735

Impact:
Low
Public Date:
2017-08-28
CWE:
CWE-125
Bugzilla:
1486144: CVE-2017-3735 openssl: Malformed X.509 IPAdressFamily could cause OOB read

The MITRE CVE dictionary describes this issue as:

While parsing an IPAddressFamily extension in an X.509 certificate, it is possible to do a one-byte overread. This would result in an incorrect text display of the certificate. This bug has been present since 2006 and is present in all versions of OpenSSL before 1.0.2m and 1.1.0g.

Find out more about CVE-2017-3735 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This flaw only exhibits itself when:
1. OpenSSL is used to display details of a local or a remote certificate.
2. The certificate contains the uncommon RFC 3779 IPAddressFamily extension.

The maximum impact of this flaw is garbled information being displayed, there is no impact on the availability of service using such a certificate. Also this flaw can NOT be used to create specially-crafted certificates. Red Hat Product Security has rated this issue as having Low security impact. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

CVSS v3 metrics

CVSS3 Base Score 5.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality None
Integrity Impact Low
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (openssl) RHSA-2018:3221 2018-10-30

Affected Packages State

Platform Package State
Red Hat JBoss Web Server 3 openssl Will not fix
Red Hat JBoss EWS 2 openssl Will not fix
Red Hat JBoss EWS 1 openssl Will not fix
Red Hat JBoss EAP 6 openssl Will not fix
Red Hat JBoss EAP 5 openssl Will not fix
Red Hat JBoss Core Services 1 openssl Will not fix
Red Hat Enterprise Linux 7 openssl098e Will not fix
Red Hat Enterprise Linux 7 OVMF Will not fix
Red Hat Enterprise Linux 6 openssl Will not fix
Red Hat Enterprise Linux 6 openssl098e Will not fix
Red Hat Enterprise Linux 5 openssl097a Will not fix
Red Hat Enterprise Linux 5 openssl Will not fix
RHEV Manager 3 mingw-virt-viewer Will not fix

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation