CVE-2017-2661

Impact:
Low
CWE:
CWE-79
Bugzilla:
1428948: CVE-2017-2661 pcs: Improper node name field validation when creating clusters leads to XSS
It was found that pcsd was vulnerable to reflected cross-site scripting (XSS) attacks while handling node names during creation or import of a cluster. An attacker could use this flaw to run javascript code in an authenticated session.

Find out more about CVE-2017-2661 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

NOTE: The following CVSS v3 metrics and score provided are preliminary and subject to review.

CVSS3 Base Score 6.1
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Low
Integrity Impact Low
Availability Impact None

Affected Packages State

Platform Package State
Red Hat Gluster Storage 3 pcs Will not fix
Red Hat Enterprise Linux 7 pcs Will not fix
Red Hat Enterprise Linux 6 pcs Will not fix

Acknowledgements

Red Hat would like to thank Microsoft for reporting this issue.
Last Modified