CVE-2017-18206

Impact:
Low
Public Date:
2017-05-09
Bugzilla:
1549861: CVE-2017-18206 zsh: buffer overrun in symlinks
A buffer overflow flaw was found in the zsh shell symbolic link resolver. A local, unprivileged user can create a specially crafted directory path which leads to a buffer overflow in the context of the user trying to do a symbolic link resolution in the aforementioned path. If the user affected is privileged, this leads to privilege escalation.

Find out more about CVE-2017-18206 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 7.5
CVSS3 Base Metrics CVSS:3.0/AV:L/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Attack Vector Local
Attack Complexity High
Privileges Required Low
User Interaction Required
Scope Changed
Confidentiality High
Integrity Impact High
Availability Impact High

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (zsh) RHSA-2018:1932 2018-06-19
Red Hat Enterprise Linux 7 (zsh) RHSA-2018:3073 2018-10-30

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 8 zsh Not affected
Red Hat Enterprise Linux 5 zsh Will not fix
Last Modified