CVE-2017-1000061

Impact:
Moderate
Public Date:
2017-03-30
CWE:
CWE-611
Bugzilla:
1437311: CVE-2017-1000061 xmlsec1: xmlsec vulnerable to external entity expansion
It was discovered xmlsec1's use of libxml2 inadvertently enabled external entity expansion (XXE) along with validation. An attacker could craft an XML file that would cause xmlsec1 to try and read local files or HTTP/FTP URLs, leading to information disclosure or denial of service.

Find out more about CVE-2017-1000061 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 6.5
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact Low

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (xmlsec1) RHSA-2017:2492 2017-08-21

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 xmlsec1 Will not fix
Red Hat Enterprise Linux 5 xmlsec1 Will not fix

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.