CVE-2016-1531

Impact:
Important
Public Date:
2016-03-02
CWE:
CWE-426
Bugzilla:
1314293: CVE-2016-1531 exim: local root privilege escalation for configurations with perl_startup

The MITRE CVE dictionary describes this issue as:

Exim before 4.86.2, when installed setuid root, allows local users to gain privileges via the perl_startup argument.

Find out more about CVE-2016-1531 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the version of exim as shipped with Red Hat Enterprise Linux 4 and 5. However, the default configurations are not affected, as they do not use 'perl_startup' directive.

Red Hat Enterprise Linux 4 is now in Extended Life Cycle phase of the support and maintenance life cycle, and Red Hat Enterprise Linux 5 is now in Production 3 Phase of the support and maintenance life cycle. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Enterprise Linux Life Cycle: https://access.redhat.com/support/policy/updates/errata/.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 6.9
Base Metrics AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 5 exim Will not fix
Red Hat Enterprise Linux 4 exim Will not fix
Unless explicitly stated as not affected, all previous versions of packages in any minor update stream of a product listed here should be assumed vulnerable, although may not have been subject to full analysis.

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation