CVE-2016-10168

Impact:
Moderate
Public Date:
2016-12-17
CWE:
CWE-190
Bugzilla:
1418986: CVE-2016-10168 gd: Integer overflow in gd_io.c
An integer overflow flaw, leading to a heap-based buffer overflow was found in the way libgd read some specially-crafted gd2 files. A remote attacker could use this flaw to crash an application compiled with libgd or in certain cases execute arbitrary code with the privileges of the user running that application.

Find out more about CVE-2016-10168 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 6.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Low
Integrity Impact Low
Availability Impact Low

Red Hat Security Errata

Platform Errata Release Date
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-php70-php) RHSA-2018:1296 2018-05-03
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-php70-php) RHSA-2018:1296 2018-05-03
Red Hat Enterprise Linux 7 (php) RHSA-2017:3221 2017-11-15

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux rh-php56-php Will not fix
Red Hat Software Collections for Red Hat Enterprise Linux rh-php71-php Not affected
Red Hat Enterprise Linux 7 gd Will not fix
Red Hat Enterprise Linux 7 libwmf Will not fix
Red Hat Enterprise Linux 6 libwmf Will not fix
Red Hat Enterprise Linux 6 gd Will not fix
Red Hat Enterprise Linux 6 php Will not fix
Red Hat Enterprise Linux 5 gd Will not fix
Red Hat Enterprise Linux 5 php53 Will not fix
Red Hat Enterprise Linux 5 libwmf Will not fix
Red Hat Enterprise Linux 5 php Will not fix

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.