CVE-2015-5239

Impact:
Moderate
Public Date:
2014-06-30
CWE:
CWE-835
Bugzilla:
1257735: CVE-2015-5239 qemu-kvm: Integer overflow in vnc_client_read() and protocol_client_msg()
An integer overflow issue was found in the VNC display driver of the QEMU emulator, which could be used by a privileged guest user to create a denial of service attack. The overflow occurred when processing a CLIENT_CUT_TEXT message with too large a payload size. The integer overflow led to an infinite loop inside the VNC driver, eventually crashing the QEMU process on the host.

Find out more about CVE-2015-5239 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the versions of kvm and xen packages as shipped with Red Hat Enterprise Linux 5.

This issue affects the versions of the qemu-kvm packages as shipped with Red Hat Enterprise Linux 6 and 7.

This issue affects the Red Hat Enterprise Linux 6 based versions of qemu-kvm-rhev packages as shipped with Red Hat Enterprise Virtualization 3.

This issue affect the Red Hat Enterprise Linux 7 based versions of the qemu-kvm-rhev packages as shipped with Red Hat Enterprise Virtualization 3.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 4
Base Metrics AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 qemu-kvm-rhev Not affected
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 qemu-kvm-rhev Not affected
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) qemu-kvm-rhev Will not fix
Red Hat Enterprise Linux 7 qemu-kvm Will not fix
Red Hat Enterprise Linux 6 qemu-kvm Will not fix
Red Hat Enterprise Linux 5 kvm Will not fix
Red Hat Ceph Storage 1.1 qemu-kvm Will not fix
RHEV Manager 3 rhev-hypervisor Will not fix
RHEV Manager 3 qemu-kvm-rhev Will not fix

Acknowledgements

Red Hat would like to thank Lian Yihan of Qihoo 360 for reporting this issue.

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.