CVE-2014-7817

Impact:
Moderate
Public Date:
2014-11-20
CWE:
CWE-227
Bugzilla:
1157689: CVE-2014-7817 glibc: command execution in wordexp() with WRDE_NOCMD specified
It was found that the wordexp() function would perform command substitution even when the WRDE_NOCMD flag was specified. An attacker able to provide specially crafted input to an application using the wordexp() function, and not sanitizing the input correctly, could potentially use this flaw to execute arbitrary commands with the credentials of the user running that application.

Find out more about CVE-2014-7817 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the version of glibc package as shipped with Red Hat Enterprise Linux 5, 6 and 7. Red Hat Product Security has rated this issue as having Moderate security impact.

Red Hat Enterprise Linux 5 is now in Extended Life Cycle phase of the support and maintenance life cycle. This issue is not currently planned to be addressed in future updates. For additional information, refer to the Red Hat Enterprise Linux Life Cycle: https://access.redhat.com/support/policy/updates/errata

CVSS v2 metrics

Base Score 3.6
Base Metrics AV:L/AC:L/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 7 (glibc) RHSA-2014:2023 2014-12-18
Red Hat Enterprise Linux 6 (glibc) RHSA-2015:0016 2015-01-07

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 5 glibc Will not fix

Acknowledgements

This issue was discovered by Tim Waugh of the Red Hat Developer Experience Team.
Last Modified