CVE-2014-0112

Impact:
Important
Public Date:
2014-04-25
IAVA:
2014-B-0090
Bugzilla:
1091939: CVE-2014-0112 struts2: ClassLoader manipulation via request parameters

The MITRE CVE dictionary describes this issue as:

ParametersInterceptor in Apache Struts before 2.3.16.2 does not properly restrict access to the getClass method, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via a crafted request. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-0094.

Find out more about CVE-2014-0112 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

Not Vulnerable. This issue only affects struts 2, it does not affect the versions of struts as shipped with various Red Hat products. A similar issue exists in struts 1, identified by CVE-2014-0114.

Applications using a third-party struts 2 library, deployed to Red Hat JBoss products, may be affected. Additional information can be found in the Red Hat Knowledgebase article: https://access.redhat.com/site/solutions/800293

CVSS v2 metrics

Base Score 7.5
Base Metrics AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

CVSS v3 metrics

CVSS3 Base Score 7.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Attack Vector Network
Attack Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Low
Integrity Impact Low
Availability Impact Low

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat JBoss Fuse 7 RHSA-2019:0910 2019-04-30

Affected Packages State

Platform Package State
Red Hat JBoss Operations Network 3 struts Not affected
Red Hat JBoss Fuse 6 struts-core Under investigation
Red Hat Enterprise Linux 5 struts Not affected

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation