CVE-2011-4718

Impact:
Moderate
Public Date:
2011-11-23
CWE:
CWE-384
Bugzilla:
996774: CVE-2011-4718 php: session fixation vulnerability allows remote hijacking of sessions

The MITRE CVE dictionary describes this issue as:

Session fixation vulnerability in the Sessions subsystem in PHP before 5.5.2 allows remote attackers to hijack web sessions by specifying a session ID.

Find out more about CVE-2011-4718 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the version of php and php53 as shipped with Red Hat Enterprise Linux 5. This issue affects the version of php as shipped with Red Hat Enterprise Linux 6 and 7. The Red Hat Security Response Team has rated this issue as having moderate security impact. This issue is not currently planned to be addressed in future updates. This issue may be mitigated with user code changes as noted in https://wiki.php.net/rfc/strict_sessions#current_solution

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 5.8
Base Metrics AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Software Collections 1 for Red Hat Enterprise Linux php54-php Will not fix
Red Hat Enterprise Linux 7 php Will not fix
Red Hat Enterprise Linux 6 php Will not fix
Red Hat Enterprise Linux 5 php53 Will not fix
Red Hat Enterprise Linux 5 php Will not fix
Last Modified

CVE description copyright © 2017, The MITRE Corporation