CVE-2009-3736

Impact:
Moderate
Public Date:
2009-11-16
Bugzilla:
537941: CVE-2009-3736 libtool: libltdl may load and execute code from a library in the current directory

The MITRE CVE dictionary describes this issue as:

ltdl.c in libltdl in GNU Libtool 1.5.x, and 2.2.6 before 2.2.6b, as used in Ham Radio Control Libraries, Q, and possibly other products, attempts to open a .la file in the current working directory, which allows local users to gain privileges via a Trojan horse file.

Find out more about CVE-2009-3736 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v2 metrics

Base Score 6.2
Base Metrics AV:L/AC:H/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 3 (gcc) RHSA-2010:0039 2010-01-13
Red Hat Enterprise Linux 3 (libtool) RHSA-2009:1646 2009-12-08
Red Hat Enterprise Linux 5 (gcc) RHSA-2010:0039 2010-01-13
Red Hat Enterprise Linux 4 (gcc) RHSA-2010:0039 2010-01-13
Red Hat Enterprise Linux 5 (libtool) RHSA-2009:1646 2009-12-08
Red Hat Enterprise Linux 4 (libtool) RHSA-2009:1646 2009-12-08

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 guile Will not fix
Red Hat Enterprise Linux 6 libtool Not affected
Red Hat Enterprise Linux 5 gcc44 Will not fix
Red Hat Enterprise Linux 5 guile Will not fix
Red Hat Enterprise Linux 4 guile Not affected
Red Hat Application Stack v2 for Enterprise Linux (v.5) unixODBC Will not fix
Last Modified

CVE description copyright © 2017, The MITRE Corporation