CVE-2008-5351

Table of Contents

Impact:
Important
Public Date:
2008-12-04
Bugzilla:
472213: CVE-2008-5351 OpenJDK UTF-8 decoder accepts non-shortest form sequences (4486841)

The MITRE CVE dictionary describes this issue as:

Java Runtime Environment (JRE) for Sun JDK and JRE 6 Update 10 and earlier; JDK and JRE 5.0 Update 16 and earlier; and SDK and JRE 1.4.2_18 and earlier accepts UTF-8 encodings that are not the "shortest" form, which makes it easier for attackers to bypass protection mechanisms for other applications that rely on shortest-form UTF-8 encodings.

Find out more about CVE-2008-5351 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux Supplementary 5 (java-1.4.2-ibm) RHSA-2009:0445 2009-04-23
Red Hat Enterprise Linux Supplementary 5 (java-1.6.0-sun) RHSA-2008:1018 2008-12-04
Red Hat Enterprise Linux AS version 4 Extras (java-1.6.0-sun) RHSA-2008:1018 2008-12-04
Red Hat Enterprise Linux Supplementary 5 (java-1.6.0-ibm) RHSA-2009:0369 2009-03-25
Red Hat Enterprise Linux AS version 4 Extras (java-1.5.0-sun) RHSA-2008:1025 2008-12-04
Red Hat Enterprise Linux AS version 4 Extras (java-1.5.0-ibm) RHSA-2009:0016 2009-01-13
Red Hat Enterprise Linux Supplementary 5 (java-1.5.0-sun) RHSA-2008:1025 2008-12-04
Red Hat Enterprise Linux AS version 4 Extras (java-1.4.2-ibm) RHSA-2009:0445 2009-04-23
Red Hat Enterprise Linux AS version 3 Extras (java-1.4.2-ibm) RHSA-2009:0445 2009-04-23
Red Hat Satellite 5.2 (RHEL v.5) (java-1.5.0-ibm) RHSA-2009:0466 2009-05-07
Red Hat Enterprise Linux AS version 4 Extras (java-1.6.0-ibm) RHSA-2009:0369 2009-03-25
Red Hat Enterprise Linux Supplementary 5 (java-1.5.0-ibm) RHSA-2009:0016 2009-01-13
Red Hat Satellite 5.2 (RHEL v.4 AS) (java-1.5.0-ibm) RHSA-2009:0466 2009-05-07
Last Modified

CVE description copyright © 2017, The MITRE Corporation