CVE-2008-3657

Table of Contents

Impact:
Low
Public Date:
2008-08-08
Bugzilla:
458966: CVE-2008-3657 ruby: missing "taintness" checks in dl module

The MITRE CVE dictionary describes this issue as:

The dl module in Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not check "taintness" of inputs, which allows context-dependent attackers to bypass safe levels and execute dangerous functions by accessing a library using DL.dlopen.

Find out more about CVE-2008-3657 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 4 (ruby) RHSA-2008:0897 2008-10-21
Red Hat Enterprise Linux 5 (ruby) RHSA-2008:0897 2008-10-21
Last Modified

CVE description copyright © 2017, The MITRE Corporation