CVE-2008-3655

Table of Contents

Impact:
Moderate
Public Date:
2008-08-08
Bugzilla:
458948: CVE-2008-3655 ruby: multiple insufficient safe mode restrictions

The MITRE CVE dictionary describes this issue as:

Ruby 1.8.5 and earlier, 1.8.6 through 1.8.6-p286, 1.8.7 through 1.8.7-p71, and 1.9 through r18423 does not properly restrict access to critical variables and methods at various safe levels, which allows context-dependent attackers to bypass intended access restrictions via (1) untrace_var, (2) $PROGRAM_NAME, and (3) syslog at safe level 4, and (4) insecure methods at safe levels 1 through 3.

Find out more about CVE-2008-3655 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 4 (ruby) RHSA-2008:0897 2008-10-21
Red Hat Enterprise Linux 2.1 (ruby) RHSA-2008:0895 2008-10-21
Red Hat Enterprise Linux 3 (ruby) RHSA-2008:0896 2008-10-21
Red Hat Enterprise Linux 5 (ruby) RHSA-2008:0897 2008-10-21
Last Modified

CVE description copyright © 2017, The MITRE Corporation