CVE-2007-0988

Table of Contents

Impact:
Moderate
Public Date:
2007-02-14
Bugzilla:
1618285: CVE-2007-0988 security flaw

The MITRE CVE dictionary describes this issue as:

The zend_hash_init function in PHP 5 before 5.2.1 and PHP 4 before 4.4.5, when running on a 64-bit platform, allows context-dependent attackers to cause a denial of service (infinite loop) by unserializing certain integer expressions, which only cause 32-bit arguments to be used after the check for a negative value, as demonstrated by an "a:2147483649:{" argument.

Find out more about CVE-2007-0988 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 5 (php) RHSA-2007:0082 2007-03-14
Stronghold 4 for Red Hat Enterprise Linux (stronghold-php) RHSA-2007:0089 2007-02-26
Red Hat Enterprise Linux 4 (php) RHSA-2007:0076 2007-02-19
Red Hat Enterprise Linux 2.1 (php) RHSA-2007:0081 2007-02-21
Red Hat Application Stack v1 for Enterprise Linux AS (v.4) (php) RHSA-2007:0088 2007-02-22
Red Hat Enterprise Linux 3 (php) RHSA-2007:0076 2007-02-19
Last Modified

CVE description copyright © 2017, The MITRE Corporation