CVE-2006-4020

Impact:
Low
Public Date:
2006-08-04
Bugzilla:
1618174: CVE-2006-4020 security flaw

The MITRE CVE dictionary describes this issue as:

scanf.c in PHP 5.1.4 and earlier, and 4.4.3 and earlier, allows context-dependent attackers to execute arbitrary code via a sscanf PHP function call that performs argument swapping, which increments an index past the end of an array and triggers a buffer over-read.

Find out more about CVE-2006-4020 from the MITRE CVE dictionary dictionary and NIST NVD.

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 2.1 RHSA-2006:0682 2006-09-21
Red Hat Application Stack v1 for Enterprise Linux AS (v.4) (php) RHSA-2006:0688 2006-10-05
Stronghold 4 for Red Hat Enterprise Linux RHSA-2006:0736 2006-12-11
Red Hat Enterprise Linux 3 (php) RHSA-2006:0669 2006-09-21
Red Hat Enterprise Linux 4 (php) RHSA-2006:0669 2006-09-21
Last Modified

CVE description copyright © 2017, The MITRE Corporation