CVE-2017-7484

Impact:
Moderate
Public Date:
2017-05-11
CWE:
CWE-862
Bugzilla:
1448078: CVE-2017-7484 postgresql: Selectivity estimators bypass SELECT privilege checks
It was found that some selectivity estimation functions did not check user privileges before providing information from pg_statistic, possibly leaking information. A non-administrative database user could use this flaw to steal some information from tables they are otherwise not allowed to access.

Find out more about CVE-2017-7484 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 4.3
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Attack Vector Network
Attack Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Low
Integrity Impact None
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-postgresql95-postgresql) RHSA-2017:1677 2017-07-05
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-postgresql95-postgresql) RHSA-2017:1677 2017-07-05
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-postgresql94-postgresql) RHSA-2017:1678 2017-07-05
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-postgresql94-postgresql) RHSA-2017:1678 2017-07-05

Affected Packages State

Platform Package State
Red Hat Satellite 5 postgresql92-postgresql Affected
Red Hat Enterprise Linux 7 postgresql Affected
Red Hat Enterprise Linux 6 postgresql Will not fix
Red Hat Enterprise Linux 5 postgresql84 Will not fix
Red Hat Enterprise Linux 5 postgresql Will not fix

Acknowledgements

Red Hat would like to thank the PostgreSQL project for reporting this issue. Upstream acknowledges Robert Haas as the original reporter.

Mitigation

External References

Last Modified