CVE-2017-3305

Impact:
Moderate
Public Date:
2017-03-17
CWE:
CWE-319
Bugzilla:
1431690: CVE-2017-3305 mysql: incorrect enforcement of ssl-mode=REQUIRED in MySQL 5.5 and 5.6
It was discovered that the MySQL client command line tools only checked after authentication whether server supported SSL. A man-in-the-middle attacker could use this flaw to hijack client's authentication to the server even if the client was configured to require SSL connection.

Find out more about CVE-2017-3305 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v3 metrics

CVSS3 Base Score 6.8
CVSS3 Base Metrics CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
Attack Vector Network
Attack Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality High
Integrity Impact High
Availability Impact None

Red Hat Security Errata

Platform Errata Release Date
Red Hat Software Collections for Red Hat Enterprise Linux 6 (rh-mysql56-mysql) RHSA-2017:2787 2017-09-21
Red Hat Software Collections for Red Hat Enterprise Linux 7 (rh-mysql56-mysql) RHSA-2017:2787 2017-09-21

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux rh-mariadb101-mariadb Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-mariadb100-mariadb Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-mysql57-mysql Not affected
Red Hat OpenStack Platform 9.0 mariadb-galera Not affected
Red Hat OpenStack Platform 8.0 (Liberty) mariadb-galera Not affected
Red Hat OpenStack Platform 11 mariadb-galera Not affected
Red Hat OpenStack Platform 10 mariadb-galera Not affected
Red Hat Mobile Application Platform On-Premise 4 rhmap-mysql-docker Not affected
Red Hat Enterprise Linux OpenStack Platform 7.0 (Kilo) for RHEL 7 mariadb-galera Not affected
Red Hat Enterprise Linux OpenStack Platform 6.0 (Juno) for RHEL 7 mariadb-galera Not affected
Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) mariadb-galera Not affected
Red Hat Enterprise Linux 7 mariadb Not affected
Red Hat Enterprise Linux 6 mysql Not affected
Red Hat Enterprise Linux 5 mysql55-mysql Not affected

Acknowledgements

Red Hat would like to thank Pali Rohár for reporting this issue.

External References

Last Modified
Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.