CVE-2016-2193

Impact:
Moderate
Public Date:
2016-03-31
Bugzilla:
1319806: CVE-2016-2193 postgresql: row security policies in prepared statements disregard user ID changes

The MITRE CVE dictionary describes this issue as:

PostgreSQL before 9.5.x before 9.5.2 does not properly maintain row-security status in cached plans, which might allow attackers to bypass intended access restrictions by leveraging a session that performs queries as more than one role.

Find out more about CVE-2016-2193 from the MITRE CVE dictionary dictionary and NIST NVD.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 4.6
Base Metrics AV:N/AC:H/Au:S/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql94-postgresql Not affected
Red Hat Software Collections for Red Hat Enterprise Linux rh-postgresql95-postgresql Not affected
Red Hat Software Collections for Red Hat Enterprise Linux postgresql92-postgresql Not affected
Red Hat Satellite 5.7 postgresql92-postgresql Not affected
Red Hat Enterprise Linux 7 postgresql Not affected
Red Hat Enterprise Linux 6 postgresql Not affected
Red Hat Enterprise Linux 5 postgresql84 Not affected
Red Hat Enterprise Linux 5 postgresql Not affected

Acknowledgements

Red Hat would like to thank the PostgreSQL project for reporting this issue. Upstream acknowledges Ashutosh Bapat as the original reporter.

Mitigation

External References

Last Modified

CVE description copyright © 2017, The MITRE Corporation

Close

Welcome! Check out the Getting Started with Red Hat page for quick tours and guides for common tasks.