CVE-2014-0190

Impact:
Low
Public Date:
2014-04-14
CWE:
CWE-476
Bugzilla:
1088142: CVE-2014-0190 qt: NULL pointer dereference flaw in QGIFFormat::fillRect

The MITRE CVE dictionary describes this issue as:

The GIF decoder in QtGui in Qt before 5.3 allows remote attackers to cause a denial of service (NULL pointer dereference) via invalid width and height values in a GIF image.

Find out more about CVE-2014-0190 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue affects the versions of qt4 as shipped with Red Hat Enterprise Linux 5 , qt3 as shipped with Red Hat Enterprise Linux 6 and 7 and qt as shipped with Red Hat Enterprise Linux 5, 6 and 7. Red Hat Product Security has rated this issue as having Low security impact. A future update may address this issue. For additional information, refer to the Issue Severity Classification: https://access.redhat.com/security/updates/classification/.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 1.9
Base Metrics AV:L/AC:M/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 7 qt Fix deferred
Red Hat Enterprise Linux 7 qt3 Fix deferred
Red Hat Enterprise Linux 6 qt3 Fix deferred
Red Hat Enterprise Linux 6 qt Fix deferred
Red Hat Enterprise Linux 5 qt4 Fix deferred
Red Hat Enterprise Linux 5 qt Fix deferred

Last Modified