Red Hat Customer Portal

Skip to main content

CVE-2013-7327

Impact:
Important
Public Date:
2014-02-06
Bugzilla:
1065108: CVE-2013-7226 CVE-2013-7327 CVE-2013-7328 CVE-2014-2020 php: multiple vulnerabilities in gdImageCrop()

The MITRE CVE dictionary describes this issue as:

The gdImageCrop function in ext/gd/gd.c in PHP 5.5.x before 5.5.9 does not check return values, which allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via invalid imagecrop arguments that lead to use of a NULL pointer as a return value, a different vulnerability than CVE-2013-7226.

Find out more about CVE-2013-7327 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

Not vulnerable. This issue did not affect the versions of php or php53 as shipped with Red Hat Enterprise Linux 5 and 6, and the versions of php54-php as shipped with Red Hat Software Collections 1, as they did not include the vulnerable function (it was introduced in PHP 5.5.0). This issue also did not affect the versions of gd as shipped with Red Hat Enterprise Linux 5 and 6.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 6.8
Base Metrics AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 4 php Not affected
Red Hat Enterprise Linux 7 php Not affected
Red Hat Enterprise Linux 6 gd Not affected
Red Hat Enterprise Linux 5 gd Not affected
Red Hat Enterprise Linux 5 php53 Not affected
Red Hat Enterprise Linux 6 php Not affected
Red Hat Enterprise Linux 7 gd Not affected
Red Hat Enterprise Linux 5 php Not affected

External References