Public Date:
1000202: CVE-2013-4277 subversion: svnserve is vulnerable to symlink attack

The MITRE CVE dictionary describes this issue as:

Svnserve in Apache Subversion 1.4.0 through 1.7.12 and 1.8.0 through 1.8.1 allows local users to overwrite arbitrary files or kill arbitrary processes via a symlink attack on the file specified by the --pid-file option.

Find out more about CVE-2013-4277 from the MITRE CVE dictionary dictionary and NIST NVD.


The Red Hat Security Response Team does not consider this issue to be a security flaw. For technical details please refer to

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 3.6
Base Metrics AV:L/AC:L/Au:N/C:N/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 7 subversion Not affected
Red Hat Enterprise Linux 5 subversion Will not fix
Red Hat Enterprise Linux 6 subversion Will not fix


Red Hat would like to thank Ben Reser of the Apache Subversion project for reporting this issue. Upstream acknowledges Daniel Shahaf of elego Software Solutions GmbH as the original issue reporter.

External References