Red Hat Customer Portal

Skip to main content

CVE-2013-4164

Impact:
Critical
Public Date:
2013-11-22
CWE:
CWE-228->CWE-122
Bugzilla:
1033460: CVE-2013-4164 ruby: heap overflow in floating point parsing

The MITRE CVE dictionary describes this issue as:

Heap-based buffer overflow in Ruby 1.8, 1.9 before 1.9.3-p484, 2.0 before 2.0.0-p353, 2.1 before 2.1.0 preview2, and trunk before revision 43780 allows context-dependent attackers to cause a denial of service (segmentation fault) and possibly execute arbitrary code via a string that is converted to a floating point value, as demonstrated using (1) the to_f method or (2) JSON.parse.

Find out more about CVE-2013-4164 from the MITRE CVE dictionary dictionary and NIST NVD.

Statement

This issue did not affect the versions of ruby as shipped with Red Hat Enterprise Linux 5.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 7.5
Base Metrics AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux 6 (ruby) RHSA-2013:1764 2013-11-25
Red Hat Software Collections 1 for Red Hat Enterprise Linux Server (v. 6) (ruby193-ruby) RHSA-2013:1763 2013-11-25
Red Hat Enterprise Linux Extended Update Support 6.2 (ruby) RHSA-2013:1767 2013-11-26
Red Hat Enterprise Linux OpenStack Platform 3.0 (ruby193-ruby) RHSA-2014:0011 2014-01-07
Red Hat Enterprise Linux Extended Update Support 6.4 (ruby) RHSA-2013:1767 2013-11-26
Red Hat Enterprise Linux Extended Update Support 6.3 (ruby) RHSA-2013:1767 2013-11-26
CloudForms Management Engine 5.4 (ruby193-ruby) RHSA-2014:0215 2014-03-11

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 4 ruby Not affected
Red Hat Enterprise Linux 7 ruby Not affected
Red Hat Enterprise Linux 5 ruby Not affected