You are here

CVE-2012-4214

Vincent (CVE) Danen's picture
Use-after-free vulnerability in the nsTextEditorState::PrepareEditor function in Mozilla Firefox before 17.0, Firefox ESR 10.x before 10.0.11, Thunderbird before 17.0, Thunderbird ESR 10.x before 10.0.11, and SeaMonkey before 2.14 allows remote attackers to execute arbitrary code or cause a denial of service (heap memory corruption) via unspecified vectors, a different vulnerability than CVE-2012-5840.

Details Source

Mitre

Public Date

2012-11-20 00:00:00

Impact

Critical

Bugzilla

CVE-2012-4214 CVE-2012-4215 CVE-2012-4216 CVE-2012-5829 CVE-2012-5839 CVE-2012-5840 Mozilla: Use-after-free and buffer overflow issues found using Address Sanitizer (MFSA 2012-105)

Bugzilla ID

877 634

CVSS Status

verified

Base Score

6.80

Base Metrics

AV:N/AC:M/Au:N/C:P/I:P/A:P

Acknowledgements

Red Hat would like to thank the Mozilla project for reporting this issue. Upstream acknowledges Abhishek Arya as the original reporter.

External References

http://www.mozilla.org/security/announce/2012/mfsa2012-105.html

Red Hat Security Errata

Platform Errata Release Date
Red Hat Enterprise Linux Optional Productivity Applications (v. 5 server) (thunderbird) RHSA-2012:1483 2012-11-20
Red Hat Enterprise Linux 6 (thunderbird) RHSA-2012:1483 2012-11-20
Red Hat Enterprise Linux 6 (firefox) RHSA-2012:1482 2012-11-20
Red Hat Enterprise Linux 5 (thunderbird) RHSA-2012:1483 2012-11-20
Red Hat Enterprise Linux 5 (firefox) RHSA-2012:1482 2012-11-20

CWE

(CWE-416|CWE-119)

Affected Packages State

Platform Package State
Red Hat Enterprise Linux version 6 xulrunner 10.0.11-1.el6_3 Fixed
Red Hat Enterprise Linux version 5 xulrunner 10.0.11-1.el5_8 Fixed