Red Hat Customer Portal

Skip to main content

CVE-2012-2652

The bdrv_open function in Qemu 1.0 does not properly handle the failure of the mkstemp function, when in snapshot node, which allows local users to overwrite or read arbitrary files via a symlink attack on an unspecified temporary file.

Details Source

Mitre

Public Date

2012-05-28 00:00:00

Impact

Moderate

Bugzilla

CVE-2012-2652 qemu: vulnerable to temporary file symlink attacks

Bugzilla ID

824 919

CVSS Status

draft

Base Score

4.60

Base Metrics

AV:L/AC:L/Au:N/C:P/I:P/A:P

CWE

CWE-367

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 6 qemu-kvm Affected
Red Hat Enterprise Linux 5 kvm Affected