Public Date:
820874: CVE-2012-2335 php: incomplete CVE-2012-1823 fix - insecure wrapper

The MITRE CVE dictionary describes this issue as:

php-wrapper.fcgi does not properly handle command-line arguments, which allows remote attackers to bypass a protection mechanism in PHP 5.3.12 and 5.4.2 and execute arbitrary code by leveraging improper interaction between the PHP sapi/cgi/cgi_main.c component and a query string beginning with a +- sequence.

Find out more about CVE-2012-2335 from the MITRE CVE dictionary dictionary and NIST NVD.


The mitigation for CVE-2012-2335 is included in the following PHP updates for Red Hat Enterprise Linux 5 and 6, which also address CVE-2012-2336 (BZ#820708):

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 5.1
Base Metrics AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 4 php Not affected
Red Hat Enterprise Linux 6 php Affected
Red Hat Enterprise Linux 3 php Not affected
Red Hat Enterprise Linux 5 php Affected
Red Hat Enterprise Linux 5 php53 Affected