Public Date:
760984: CVE-2011-4578 acpid: Unsafe umask for actions executed by acpid

The MITRE CVE dictionary describes this issue as:

event.c in acpid (aka acpid2) before 2.0.11 does not have an appropriate umask setting during execution of event-handler scripts, which might allow local users to (1) perform write operations within directories created by a script, or (2) read files created by a script, via standard filesystem system calls.

Find out more about CVE-2011-4578 from the MITRE CVE dictionary dictionary and NIST NVD.


This issue affects the versions of the acpid package, as shipped with Red Hat Enterprise Linux 4, 5, and 6. The Red Hat Security Response Team has rated this issue as having low security impact, a future update may address this flaw in acpid.

CVSS v2 metrics

NOTE: The following CVSS v2 metrics and score provided are preliminary and subject to review.

Base Score 3.6
Base Metrics AV:L/AC:L/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None

Find out more about Red Hat support for the Common Vulnerability Scoring System (CVSS).

Affected Packages State

Platform Package State
Red Hat Enterprise Linux 5 acpid Fix deferred
Red Hat Enterprise Linux 4 acpid Will not fix
Red Hat Enterprise Linux 6 acpid Fix deferred